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Due Tuesday, November 9
th

, 12:00 midnight 

 

Problem 1 ï Sensitivity of the solution (Hand calculation) 

 
A cantilever beam with a hollow circular section with outside diameterd and wall 

thicknesst is modeled with one beam finite element. The resulting static equilibrium 

equations can be expressed as 
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Where I is the area moment of inertia of the cross section, Eis Youngôs modulus, and 

l the length. Determine the displacements, iY , and the sensitivities of the deflections,  

/iY dµ µand /iY tµ µ( 1,2)i= , for the following data: 630 10E= ³ psi, 20l = in, 2d= in, 

0.1t= in, 1 100P= lb and 2 0P = . 

 

Solution: 
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To calculate the sensitivity of the deflections: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Therefore, the results are as follows: 
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Problem 2 ï Optimization of a four-bar truss (MatLab)  

 
 

Consider the four-bar truss shown in the figure, in which members 1, 2, and 3 have the 

same cross-sectional area 1x and the same length l , while member 4 has an area of cross 

section 2x and length 3l. The truss is made of a lightweight material for which Youngôs 

modulus and the weight density are given by 630 10³ psi and 0.03333lb/in
3
, respectively. 

The truss is subjected to the loads 1 10,000P= lb and 2 20,000P = lb. The weight of the 

truss per unit value of l can be expressed as 

1 2 1 23 (1)(0.03333) 3(0.03333) 0.1 0.05773f x x x x= + = +  

The weight of the truss is to be minimized with constraints on the vertical deflection Ad  

of the joint A and the stresses in members 1 and 4. The maximum permissible deflection 

of joint A is 0.001 in and the permissible stresses in members are max 8333.333s = psi 

(tension) and min 4948.5714s =- psi (compression). Solve this optimization problem in 

Matlab minf  with 1l =  and the constraints | | 0.001Ad ¢  in, 1 8333.333s¢ psi and 

2 4948.5714s²- psi. 

 

In order to further verify your results, resolve the optimization problem using the 

following analytical expressions: 

 

The vertical deflection of joint A can be expressed as 

1 2

0.006 0.003464
A

x x
d= +  

and the stresses in members 1 and 4 can be written as 
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1 4

1 1 2 2

5(10,000) 50,000 2 3(10,000) 34,640
,

x x x x
s s= = =- =-  

Therefore, the optimization problem can be stated as a separable programming problem 

as follows: 

Minimize ( )1 2 1 2, 0.1 0.05773f x x x x= +  

Subject to 

1 2 1 2

0.006 0.003464 50,000 34,640
0.001 0, 8333.333, 4948.5714

x x x x
+ - ¢ ¢ - ²-  

 

 

Solution: 

 

The objective function is: 

 
 

MATLAB Modifications:  

In order to use the MATLAB optimization function fmincon, the functions objfun, 

confun, optimize_main and truss_solver were created. The Plane Truss solver provided in 

HW1 was then modified to provide the required outputs.  

Objfun.m:  
Modified to include the objective function provided. 
f = 0.1*x(1) + 0.05773*x(2);  

 

confun.m: 
The maximum displacement at point A, the tensile stress in member 1 and the  

compressive stress in member 4 are extracted from the plane truss solver program by 

calling the function truss_solver. These are then inputted into the nonlinear inequality 

constraints according to the problem specification.  
[disp_a, s1, s2]= truss_solver(x);  

  
% Nonlinear inequality constraints  
  c = [disp_a -  .001;  
       s1 -  8333.333;  
       - s2 -  4948.5714];  

  
% Nonlinear equality constraints  
ceq = [];  

 

optimize_main.m: 
An arbitrary starting guess at the solution is inputted, and fmincon called.  
x0 = [9 9];     % Make a starting guess at the solution  
options = optimset( 'Algorithm' , 'active - set' , 'Display' , 'iter' );  
[x,fval] = fmincon(@objfun,x0,[],[],[],[],[],[],@confun,options)  

 

Truss_solver.m: 
Specifies the area of members 1, 2 and 3 as x1, and that of member 4 as x(2). Calls the 
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main plane truss program, then extracts the absolute maximum displacement of point A 

from the displacement solution, and the stresses from members 1 and 4.  
include_variables;  

  
A= [x(1) x(1) x(1) x(2)]';  
Main  

  
disp_a = abs(d(8));  
s1= stress(1);  
s2= stress(4);  

 

Main.m:  
Suppress the clear commands. 
% clc;                    % clear the command window  
% clear all;              % clear all the variables in the workspace  
% close all;    

 

Include_variables.m: 
Make the stress variable global, so that it can be extracted in the truss_solver program. 
global  stress  

 

InputGrid.m:  
Input the truss geometry and element connectivity matrix.  
nsd = 2;        % number of spacial dimensions  
nel = 4;        % number of total elements  
nno = 4;        % number of total nodes  
nen = 2;        % number of nodes on each element  

  
h = sqrt(4 - 3)/2 ;  

  
Nodes =      [0, 0, sqrt(3)/2, sqrt(3);    % Define the nodal x and y 

positions  
              0, 2*h, h, 0];  

           

  
Elems=[2, 1, 3, 1;        % Define the global node number 

(connectivity)  
       3, 3, 4, 4];       % in each truss element  

 

Input Data.m: 
Input the loads P1=10,000lb and P2= 20,000lb in the y direction of nodes 3 and 4, the 

youngôs modulus E, and apply essential BCs in the x and y directions on nodes 1 and 2.  
P = [10e3 20e3];             % P is the applied load in Nt  

  
alpha = 0;           % Acting angle of the applied load (enter in 

radians)  

  

  
f(6)= - P(1);  
f(8)= - P(2);        % Define the load vector (here given   
                                          % directly in global 

coordinates  
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                                          % (node 2, x -  and y -

directions,  
                                          % so degrees of freedom 3 and 

4)  

  
E = ones(nel,1)*30e6;    
 

debc = [1, 2, 3, 4];      % Define the list of global degrees of 

freedom  
                                % which have EB conditions  

  
ebcVals = zeros(length(debc),1); % The specified values of the EB 

conditions  

 

 

Postprocessor.m: 

Suppress all the plotting and printing commands.  

 

Results: 
 
                                Max     Line search  Directional  First - order  

 Iter F - count        f(x)   constraint   steplength   derivative   optimality Procedure  

    0      3      1.41957   5.157e - 005                                         Infeasible 

start point  

    1      6      1.48918   2.538e - 006            1        0.115        0 .456    

    2      9      1.49297   6.545e - 009            1        0.115      0.00371    

    3     12      1.49297   3.215e - 011            1      0.00138      0.00197  Hessian 

modified   

    4     21      1.49296    6.35e - 011       0.0156     - 0.00241      0.00175  Hessian 

modified   

    5     29      1.49295   1.851e - 010       0.0313     - 0.00238      0.00169  Hessian 

modified   

    6     36      1.49293   6.377e - 010       0.0625      - 0.0023      0.00159  Hessian 

modified   

    7     42      1.49289   2.1 91e- 009        0.125     - 0.00215      0.00139  Hessian 

modified   

    8     47      1.49283    6.66e - 009         0.25     - 0.00186      0.00105  Hessian 

modified   

    9     51      1.49277   1.469e - 008          0.5     - 0.00131     0.000529  Hessian 

modified   

   10     54      1.49276   1.157e - 008            1    - 0.000263    1.73e - 005  Hessian 

modified   

   11     57      1.49277   6.547e - 013            1       0. 0434    1.15e - 007  Hessian 

modified   

 

Local minimum found that satisfies the constraints.  

 

Optimization completed because the objective function is non - decreasing in  

feasible directions, to within the default value of the function tolerance,  

and constrai nts were satisfied to within the default value of the constraint tolerance.  

 

<stopping criteria details>  

 

Active inequalities (to within options.TolCon = 1e - 006):  

  lower      upper     ineqlin   ineqnonlin  

                                     1 

 

x =  

 

    9.4640    9.4644  

 

 

fval =  
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    1.4928  

 

 

Thus, the optimized areas are: 

x1 = 9.4640 

X2 = 9.4644 

 

 

 

Results Verification with Analytical Expressions 

 

The analytical expressions given in the problem are: 

 

 
 

 

MATLAB Modifications:  

The analytical expressions were simply inputted into the constraints function confun. 

 

Confun.m: 
% Nonlinear inequality constraints  
  c = [.006/x(1) + .003464/x(2) -  .001;  
       50000/x(1) -  8333.333;  
       34640/x(2) -  4948.5714];  

  
% Nonlinear equality constraints  
ceq = [];  

 

 

Results: 

 

 
                                Max     Line search  Directional  First - order  

 Iter F - count        f(x)   constraint   steplength   derivative   optimality Procedure  

    0      3      1.44843    3.13e - 005                                         Infeasible 

start point  

    1      6      1.49168   1.005e - 006            1        0.115        0.305    
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    2      9      1.49315   1.278e - 009            1         0.11      0.0 0257    

    3     12      1.49313   1.752e - 010            1     - 0.00302      0.00328  Hessian 

modified   

    4     21      1.49312   2.369e - 010       0.0156     - 0.00324      0.00241  Hessian 

modified   

    5     29       1.4931   4.788e - 010       0.0313     - 0.00319      0.00233  Hessian 

modified   

    6     36      1.49305   1.383e - 009       0.0625     - 0.00309      0.00218  Hessian 

modified   

    7     42      1.49298   4.477e - 009        0.125     - 0.00289      0.00191  Hessian 

modified   

    8     47      1.49286   1.327e - 008         0.25      - 0.0025      0.00143  Hessian 

modified   

    9     51      1.49274   2.848e - 008          0.5     - 0.00175     0.000713  Hessian 

modified   

   10     54      1.49273   2.081e - 008            1    - 0.000288    3.11e - 005  Hessian 

modified   

   11     57      1.49276   3.591e - 012            1       0.0337    1.07e - 006  Hessian 

modified   

 

Local minimum found that satisfies the constraints.  

 

Optimization completed because the objective function is non - decreasing in  

feas ible directions, to within the default value of the function tolerance,  

and constraints were satisfied to within the default value of the constraint tolerance.  

 

<stopping criteria details>  

 

Active inequalities (to within options.TolCon = 1e - 006):  

  lower      upper     ineqlin   ineqnonlin  

                                     1 

 

x =  

 

    9.4639    9.4642  

 

 

fval =  

 

    1.4928  

 

 

As expected, the results are very close to each other. The solution is correct.  

 

 

 

Problem 3ï Optimization of a simply supported beam (MatLab) 

 
A simply supported beam, with a uniform rectangular cross section, is subjected to both 

distributed and concentrated loads as shown in the figure. It is desired to find the cross 
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section of the beam to minimize the weight of the beam while ensuring that the maximum 

bending stress induced in the beam does not exceed the permissible stress 0( )s of the 

material and the maximum deflection of the beam does not exceed a specified limit 0( )d . 

The data of the problem are 510P= N, 6

0 10p = N/m, 1L=m, 207E= GPa, weight 

density ( ) 76.5wr = kN/m
3
, 0 220s= MPa and 0 0.02d= m. Solve the optimization 

problem assuming that the cross-sectional dimensions of the beam are restricted as 

1 2x x¢ , 10.04 0.12m x m¢ ¢ , and 20.06 0.20m x m¢ ¢ . Note: Due to symmetry, the 

maximum bending stress and deflection occur at the middle. The bending stress can be 

computed from 21

2

Mx

I
s= , where the moment of inertia is 3

1 2

1

12
I x x= . 

Solution: 

 In order to optimize the cross section of the beam, we first compiled the programs 

in the beam solver into a single program with cross section dimensions as inputs and 

maximum moment and deflection as outputs. The program used 60 linear, two-node 

elements to model the beam. We also created a program that uses the analytical solution 

shown below to optimize the beam. Again, we used the Matlab optimization function 

fmincon to solve the problem, creating the confun functions to return inequalities for FE 

and analytical methods and objfun to calculate the weight of the beam.  

  

Analytical Solution 
2

30 0
1 2

4 3 3 2

0 0

1
,

2 2 12

1
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2

0
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Matlab functions 

¶ BeamSolver ς packaged beam finite element analysis program 

¶ Objfun ς calculates the weight of the beam 

¶ confunFE ς uses BeamSolver to check inequalities for given dimensions 

¶ confunAnal ς uses analytical solution to check inequalities for given dimensions 

¶ main ς runs the optimizations 

¶ plotweights ς visualizes the optimization 

 

Finite Element Optimization 

                                Max     Line search  Directional  First-order  

 Iter F-count        f(x)   constraint   steplength   derivative   optimality Procedure  

    0      3    7.65e+006         9.88                                         Infeasible start point 
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    1      7 1.93167e+006          4.9          0.5   -1.08e+006    3.81e+006    

    2     11       492572         2.41          0.5   -5.44e+005     1.9e+005    

    3     15       128039        1.165          0.5   -2.75e+005    9.52e+004    

    4     19      34526.6       0.5425          0.5    -1.4e+005    4.76e+004    

    5     23      9958.93       0.2312          0.5   -7.27e+004    2.38e+004    

    6     27      3222.22      0.07562          0.5    -3.9e+004    1.19e+004    

    7     31      1736.64    -0.002188          0.5      -2e+004    7.84e+003    

    8     35      1641.27    -0.003655          0.5      -1e+004     1.1e+003    

    9     39      1601.15    -0.001828          0.5   -9.69e+003          216    

   10     43      1582.65   -0.0009138          0.5   -9.53e+003          241    

   11     47      1573.73   -0.0004569          0.5   -9.45e+003          141    

   12     51      1569.34   -0.0002285          0.5   -9.43e+003         63.5    

   13     55      1567.17   -0.0001142          0.5   -9.39e+003         63.4    

   14     59      1566.09  -5.711e-005          0.5   -9.39e+003         29.3    

   15     63      1565.55  -2.856e-005          0.5   -9.36e+003         44.9    

   16     67      1565.28  -1.428e-005          0.5   -9.36e+003         14.6    

   17     71      1565.15  -7.139e-006          0.5   -9.37e+003         12.4  Hessian modified   

   18     75      1565.08   -3.57e-006          0.5   -9.36e+003         64.2  Hessian modified   

   19     78      1565.01            0            1   -9.35e+003         91.8  Hessian modified   

 

Local minimum possible. Constraints satisfied. 

 

fmincon stopped because the size of the current search direction is less than 

twice the default value of the step size tolerance and constraints were  

satisfied to within the default value of the constraint tolerance. 

 

<stopping criteria details> 

 

Active inequalities (to within options.TolCon = 1e-006): 

  lower      upper     ineqlin   ineqnonlin 

                                     5 

 

xFE = 

 

    0.1023    0.2000 

 

 

fvalFE = 

 

  1.5650e+003 

 

Analytical Optimization  

                                Max     Line search  Directional  First-order  

 Iter F-count        f(x)   constraint   steplength   derivative   optimality Procedure  

    0      3    7.65e+006         9.88                                         Infeasible start point 

    1      7 1.93167e+006          4.9          0.5   -1.08e+006    3.81e+006    



  

MAE 4700/5700 (Fall 2009)              Homework 10  Computational design  

Finite Element Analysis for  Mechanical & Aerospace Design      Page 11 of 22 

    2     11       492572         2.41          0.5   -5.44e+005     1.9e+005    

    3     15       128039        1.165          0.5   -2.75e+005    9.52e+004    

    4     19      34526.6       0.5425          0.5    -1.4e+005    4.76e+004    

    5     23      9958.93       0.2312          0.5   -7.27e+004    2.38e+004    

    6     27      3222.22      0.07562          0.5    -3.9e+004    1.19e+004    

    7     31      1736.12    -0.002188          0.5      -2e+004    7.85e+003    

    8     35      1640.94    -0.003684          0.5   -9.97e+003    1.14e+003    

    9     39      1600.94    -0.001842          0.5   -9.65e+003          309    

   10     43      1582.42    -0.000921          0.5    -9.5e+003          192    

   11     47      1573.49   -0.0004605          0.5   -9.42e+003          116    

   12     51      1569.11   -0.0002303          0.5   -9.38e+003         62.6    

   13     55      1566.93   -0.0001151          0.5   -9.37e+003         32.3    

   14     59      1565.85  -5.757e-005          0.5   -9.36e+003         16.4    

   15     63      1565.31  -2.878e-005          0.5   -9.35e+003         8.27    

   16     67      1565.04  -1.439e-005          0.5   -9.35e+003         4.15    

   17     71      1564.91  -7.196e-006          0.5   -9.35e+003         2.08  Hessian modified   

   18     75      1564.84  -3.598e-006          0.5   -9.35e+003         1.04  Hessian modified   

   19     79      1564.81  -1.799e-006          0.5   -9.35e+003         0.52  Hessian modified   

   20     83      1564.79  -8.995e-007          0.5   -9.35e+003         0.26  Hessian modified   

 

Local minimum possible. Constraints satisfied. 

 

fmincon stopped because the size of the current search direction is less than 

twice the default value of the step size tolerance and constraints were  

satisfied to within the default value of the constraint tolerance. 

 

<stopping criteria details> 

 

Active inequalities (to within options.TolCon = 1e-006): 

  lower      upper     ineqlin   ineqnonlin 

                                     5 

 

xAnal = 

 

    0.1023    0.2000 

 

 

fvalAnal = 

 

  1.5648e+003 

 

Optimization Results  

Method  X1, m  X2, m  Weight, N  

Finite Element  0.102290 0.200000 1565.0 
Analytical  0.102270 0.200000 1564.8 
Error  0.02% 0.00% 0.01% 
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The maximum error in the optimization between finite element and analytical methods 

was 0.02% in the dimension x1, which is extremely close. 

 

Problem 4 ï Design Optimization of a plate with a hole (ANSYS).  
 A square plate with a hole in the center has a uniform pressure of 10 ksi applied to 
the hole.  The objective of this example is to use the design optimization feature in 
ANSYS to modify the dimensions of the plate and the hole in order to minimize the 
volume of the plate without exceeding a maximum von Mises stress of 32.5 ksi.   
 
One quarter of the plate will be modeled and Plane 2 elements with a default mesh 
density will be used. 
 
Design Variables: 
This model will have the plate height, width, thickness and the radius of the hole 
parameterized.  The ranges are as follows: 

Parameter Minimum Value Maximum Value 

Height (H) 10 in 15 in 

Width (W) 10 in 15 in 

Thickness (T) 0.1 in 0.25 in 

Radius (R) 1.0 in 2.5 in 

 
State Variable: 
The maximum von Mises equivalent stress will be limited to 32.5 ksi. 
 
Design Objective: 
Minimize the volume of the plate. 
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The plate has a Youngôs Modulus of 30x103 ksi and Poissonôs Ratio of 0.3.   

 

A List of ANSYS commands: 

1. Parameters -> Scalar Parameters -> H=12, W=12, R=1.5, T=0.2 & PlotCtrls -> 

Numbering -> Line Ok. 

2. Preprocessor -> Element Type -> Add -> Structural -> Solid Plane 82. Ok & Options -

> Plane strs w/ thk Ok. Real Constants -> Add -> Thickness: T. Material Props -> 

Material Models -> Structural -> Linear -> Elastic -> Isotropic -> Ex=30e3, Prxy = 0.3 

3. Modeling -> Create -> Areas -> Rectangle -> By Dimensions -> X1=0, X2=W, Y1=0, 

Y2=H. Create -> Solid Circle -> Radius=R. Operate -> Booleans -> Subtract -> Areas -> 

Click the Square & Apply, and Click the circle & Ok. 

4. Meshing -> MeshTool -> Lines -> Lines 2 & 3 NDIV=6 & Lines 9, 10 & 5 NDIV=10 

-> Mesh. 

5. Preprocessor -> Define Loads -> Apply -> Structural -> Displacement -> Symmetry 

B.C. -> On Lines -> Pick lines 9 & 10. Pressure -> On Lines -> Pick line 5, value =10. 

6. Solve -> Current LS -> Ok. 

7. General Postproc -> Plot Results -> Contour Plot -> Nodal Solution -> Stress & von 

Mises. List Results -> Sorted Listing -> Sort Nodes -> Stress & von Mises. 

8. Parameters -> Get Scalar Data -> Results Data & Global Measures -> Stress & von 

Mises, Name: SMAX. General Postproc -> Element Table -> Define Table -> Add -> 

Geometry & Elem volume, Lab: VOLUME. Sum of Each Item -> Ok. Parameters -> Get 

Scalar Data -> Results Data & Elem Table Sums & Ok, Name: VOLUME. 

9. File -> Write DB Log File -> Plate & Ok. 

10. Design Opt -> Analysis File -> Create & Ok. Assign -> Plate & Ok. 

11. Design Variables -> Add -> H, MIN: 10, MAX: 15 & Apply, W, MIN: 10, MAX: 15 

& Apply, R, MIN: 1, MAX: 2.5 & Apply, T, MIN: 0.1, MAX: 0.25 & Ok. 

12. State Variables -> Add -> Select SMAX -> MAX=32.5 & Ok. 

13. Objective -> Select VOLUME & Ok. 

14. Method/Tool -> Sub-Problem & Ok. Maximum Iterations: 10 & Ok 

15. Run -> Ok. 

16. Design Sets -> List & Ok. 

17. Graphs/Tables -> XVAROPT: SMAX, NVAR: H,R,T, and W & Ok. 

18. Parameters -> Scalar Parameters -> H=value of best set, W=value of best set, 

R=value of best set, T=value of best set & Close. Solution -> Solve -> Current LS & Ok. 

General Postproc -> Plot Results -> Contour Plot -> Nodal Solution -> Stress & von 

Mises. 
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Figure 1: Mesh and Loading Conditions 

 
Figure 2: Initial Configuration Von Mises Stress 
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Figure 3: Optimal Configuration Von Mises Stress 

 
Figure 4: Parameter Variation vs. Von Mises Stress 
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Design Sets List: 

 

LIST OPTIMIZATION SETS FROM SET   1 TO SET  11 AND SHOW 

ONLY OPTIMIZATION PARAMETERS. (A "*" SYMBOL IS USED TO INDICATE 

THE BEST LISTED SET) 

SET  1        SET  2        SET  3        SET  4  

                 (FEASIBLE)    (FEASIBLE)    (FEASIBLE)    (FEASIBLE)   

 SMAX    (SV)     17.413        17.159        17.717        17.790     

 H       (DV)       12.000        14.236        12.688        12.345     

 W       (DV)      12.000        12.286        13.090        11.601     

 R       (DV)       1.5000        1.5820        2.2718        2.1891     

 T       (DV)       0.20000       0.20386     0.10050       0.18732     

 VOLUME  (OBJ)       28.447        35.254        16.283        26.124     

 

                    SET  5        SET  6        SET  7        SET  8  

                 (FEASIBLE)    (FEASIBLE)    (FEASIBLE)    (FEASIBLE)   

 SMAX    (SV)      17.400        17.753        18.015        18.157     

 H       (DV)      13.476        12.649        10.971        10.283     

 W       (DV)      10.350        14.947        10.097        10.028     

 R       (DV)      1.5209        1.9475        2.2551        2.4303     

 T       (DV)      0.11687       0.12263     0.10495       0.10157     

 VOLUME  (OBJ)     16.088        22.821        11.206        10.002     

 

                   *SET  9*       SET 10        SET 11  

                  (FEASIBLE)    (FEASIBLE)    (FEASIBLE)   

 SMAX    (SV)      18.357         17.934         18.264     

 H       (DV)      10.081         11.374         10.030     

 W       (DV)      10.014         10.011         10.286     

 R       (DV)      2.4812         2.4933         2.4937     

 T       (DV)      0.10056        0.10037        0.10037     

 VOLUME  (OBJ)     9.6653         10.939         9.8646     

 

 

 

 

Problem 5 ï Design optimization of a support bracket (ANSYS) 

A bracket is to be designed that will support a 5000 Pa load.  A 2 m diameter pipe is 

located between the applied load and the wall where the bracket is to be mounted.  The 

center of the pipe is 20 m from the mounting wall.  The bracket must be designed around 

the existing pipe and it must be at least 0.5 m from the pipe.  The bracket is constructed 

from structural steel, which has a modulus of elasticity of 200 GPa and Poissonôs ratio of 

0.3. 
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 The dimensions of the bracket (shown in the figure below) are to be optimized in 

order to minimize the volume of the bracket without exceeding a maximum von Mises 

stress of 100 kPa.   

 

 

 
 

Note:  All dimensions are in meters. 

 

 

Initial Conditions:  

 

The initial dimensions are listed in the table below. 

 

Pipe 

5000 Pa 

R2 

R1 

5 5 20 

10 

30 - W W 

H 

10 - H 
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Parameter: Initial Value 

H 0 m 

R1 1 m 

R2 2 m 

T 0.3 m 

W 0 m 

 

Computational Domain and Sub-Domains: 

 

It is recommended that the computational domain be constructed by creating 

keypoints with parameterized coordinates.  Lines and the fillet radius will be created 

using the keypoints.  Area 1 will be created using the lines and Area 2 is a solid circle.  

Boolean operations will be used to combine the areas to generate the computational 

domain.   

 

 
 

 

The values that that should be used to parameterize the coordinates of the keypoints are 

shown in the table below.  

 

Keypoint X value Y value 

1 0 0 

2 30-W W 

3 30 10 

4 25 10 

5 0 10 

 

Design Optimization: 

 

 For this problem, the sub-problem formulation with a maximum of 30 iterations 

should be used.  The design variables and their limits, the state variables, and objective 

function are: 

1 

2 

3 4 5 

Area 1 

Area 2 
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Design Variables and their Limits: 

Parameter: Lower Limit Upper Limit 

H 0 m 5 m 

R1 0 m 5 m 

R2 1.5 m 5 m 

T 0.25 m 0.5 m 

W 0 m 5 m 

 

State Variables: 

The maximum von Mises stress should not exceed 100 kPa. 

 

Objective Function: 

Minimize the volume of the bracket. 

 

Report: 

1. ANSYS Report Form. 

2. Mesh Plot. 

3. Von Mises equivalent stress plot for the initial conditions. 

4. List of the design iterations. 

5. List of parameters for the optimal design. 

6. Von Mises equivalent stress plot for the optimal design. 

 

Solution: 

P=-5000 Pa uniformly on the right top corner, E=200 GPa, v=0.3, von Misesmax=100 kPa. 

0 Ò H Ò 5m, 0 Ò R1 Ò 5m, 1.5m Ò R2 Ò 5m, 0.25m Ò T Ò 0.5m, 0 Ò W Ò 5m 

Initial Parameters: 

H = 0 m, R1 = 1 m, R2 = 2 m, T = 0.3 m, W = 0 m. 

 A List of ANSYS commands: 

1. Parameters -> Scalar Parameters -> H=0, R2=1, R2=2, T=0.3, W=0 & PlotCtrls -> 

Numbering -> Line Ok. 

2. Preprocessor -> Element Type -> Add -> Structural -> Solid Plane 82. Ok & Options -

> Plane strs w/ thk Ok. Real Constants -> Add -> Thickness: T. Material Props -> 

Material Models -> Structural -> Linear -> Elastic -> Isotropic -> Ex=200e9, Prxy = 0.3 

3. Modeling -> Create -> Keypoints -> In Active CS -> 1, 0, 0 & 2, 30-H, W & 3, 30, 10 

& 4, 25, 10 & 5, 0, 10. Lines -> Straight Line -> Connect all of them. Lines -> Line Fillet 

-> Select line 1 and 2 (bottom and right) -> radius =R1, keypoint 8 at the center -> Areas 

-> Arbitrary -> By lines -> Select all the lines. Create -> Solid Circle -> Radius = R2 at 

(20,10). Operate -> Booleans -> Subtract -> Areas -> Click the quadrilateral & Apply, 

and Click the circle & Ok. 

4. Meshing -> MeshTool -> Lines -> All the lines (except arcs) NDIV=15 & All the arcs 

NDIV=20 -> Mesh. 

5. Preprocessor -> Define Loads -> Apply -> Structural -> Displacement ->  On Lines -> 

Select the left side, All DOF. Pressure -> On Lines -> Pick line 4 (the top right corner), 

value =5000. 
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6. Solve -> Current LS -> Ok. 

7. General Postproc -> Plot Results -> Contour Plot -> Nodal Solution -> Stress & von 

Mises. List Results -> Sorted Listing -> Sort Nodes -> Stress & von Mises. 

8. Parameters -> Get Scalar Data -> Results Data & Global Measures -> Stress & von 

Mises, Name: SMAX. General Postproc -> Element Table -> Define Table -> Add -> 

Geometry & Elem volume, Lab: VOLUME. Sum of Each Item -> Ok. Parameters -> Get 

Scalar Data -> Results Data & Elem Table Sums & Ok, Name: VOLUME. 

9. File -> Write DB Log File -> Bracket & Ok. 

10. Design Opt -> Analysis File -> Create & Ok. Assign -> Plate & Ok. 

11. Design Variables -> Add -> H, MIN: 0, MAX: 5 & Apply, R1, MIN: 0, MAX: 5 & 

Apply, R2, MIN: 1.5, MAX: 5 & Apply, T, MIN: 0.25, MAX: 0.5 & Apply, W, MIN:0, 

MAX:5 &  Ok. 

12. State Variables -> Add -> Select SMAX -> MAX=100000 & Ok. 

13. Objective -> Select VOLUME & Ok. 

14. Method/Tool -> Sub-Problem & Ok. Maximum Iterations: 30 & Ok 

15. Run -> Ok. 

16. Design Sets -> List & Ok. 

17. General Postproc -> Plot Results -> Contour Plot -> Nodal Solution -> Stress & von 

Mises. 

 

The results are as follows: 
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The above figure displays the mesh used for the initial parameters, and Figure 17 displays 

that the initial design is far from exceeding the maximum von Mises stress, 100 kPa. 

List of parameters for the optimal design (Set 14): 

H = 4.98147735, R1 = 4.50450292, R2 = 4.56062431, T = 0.250651808, W = 

2.10051204 

=> SMAX     = 98687.6778, VOLUME   = 52.6827878 

Lastly, von Mises equivalent stress plot for the optimal design is as shown below. 

 


